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Issue
How to use the Telnet command to troubleshoot network connectivity and check for blocked network ports.
Product Line
TAC INET, TAC Vista, Andover Continuum, Satchwell MicroNet, Satchwell Sigma, TAC IA Series, Field Devices, EcoStruxure Building Operation, Other, Pelco, EcoStruxure Building Expert, Access Expert, Security Expert
Environment
TCP/IP Communication
Command Prompt
Telnet Command
Cause
Suspect certain network ports are blocked and need to verify
Resolution
Note:- Telnet operates using the TCP protocol. UDP connectivity cannot be tested using Telnet.
Open Windows Command Prompt
Enter :telnet <address_of_remote_server> <port_number>" - telnet 192.168.1.2 443
Result if Port open: blank window with blinking cursor
Result if Port closed: error message displayed similar to "Connecting To 192.168.1.2…Could not open connection to the host, on port xx: Connect failed"
The example above test for connectivity against the remote server that has the IP address of 192.168.1.2 over port 443