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AMT not receiving Data

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AMT not receiving Data

Picard Product_Support
‎2020-11-30 08:00 AM

Last Updated: Administrator CraigEl Administrator ‎2022-08-07 10:28 PM

Issue

  • AMT has stopped receiving data
  • AMT is not receiving data
  • A new link added to a system, is not sending messages or transactions

Product Line

TAC INET

Environment

I/NET

Cause

AMT can stop receiving data for several reasons.

  • Connection between Remote Client with I/O and SQL is broken
  • AMT is Paused
  • Communication to the device is not functioning
  • AMT Masking is not set correctly
  • Host Masking is not set correctly
  • Point Masking is not set correctly
  • Door Editor Masking is not Set
  • The software has frozen
  • I/NET has reached its maximum online event size and FIFO is not working (very rare)
  • Other

Resolution

Connection between Remote Client with I/O and SQL PC is broken.

  1. Check that no other I/NET PCs are connected to the SQL database. This may include an instance of I/NET installed on the SQL PC
  2. Restart the I/Net Remote Client with I/O to re-establish the connection with the SQL Server
  3. Wait several minutes for data to update.
  4. If this fails, ensure that there are no firewalls or communication failures between the 2 PCs.
  5. If using I/NET v2.42 there have been instances where this version does not pass events to the SQL Server.  This is fixed in v2.43 or greater.

AMT is paused

  1. Right-click anywhere in an open Alarm/Transaction/Message window
  2. The bottom choice is either "Pause" or "Resume"
  3. If it is "Resume" click on that and AMT function will be restored

Communication to the device is not functioning

  1. Minimize AMT and open I/NET
  2. Connect to the controller
  3. Select Summary>Controller
  4. If you see values and get no error messages this is not the issue
  5. If you cannot see values or get a "No Entries in Database" error, determine why communication is down

AMT Masking is not set correctly

  1. In AMT Select Edit>Configuration
  2. Note the current settings, take a screen shot and save it if possible
  3. For troubleshooting purposes, select all of the check boxes under "Messages/Alarm"
  4. Restart the I/O server
  5. In I/NET trigger a point to go into alarm or send a message
  6. Check AMT for successful delivery

Host Masking is not set correctly (TCP/IP only)

  1. Right-click on the I/O server and select Configure
  2. Modify the Active Profile
  3. On the bottom of the screen click on "Host Masks"
  4. Select any NPR or 527
  5. Note the current settings
  6. Check all boxes
  7. Click okay
  8. Repeat 4-7 for all NPR or 527 devices
  9. Restart the I/O server
  10. In I/NET trigger a point to go into alarm or send a message
  11. Check AMT for successful delivery

Point Masking not set correctly

  1. Connect to a controller that you expect to receive messages from
  2. Select Edit>Controller>Resident I/O
  3. Modify a point you expect to receive messages from
  4. Ensure that the appropriate Mask bits are set
  5. Ensure that there is a priority set for both Messages and Alarms
  6. Click okay
  7. Go to the controller summary and attempt to trigger a message or alarm

Door Editor Masking is not Set

  1. Connect to a controller that you expect to receive messages from
  2. Select Edit>Controller>Doors
  3. Modify a door you expect to receive messages from
  4. Ensure that the appropriate Mask bits are set
  5. Ensure that there is a priority set for both Transactions and Alarms
  6. Click okay
  7. Attempt to trigger a message or alarm

The software has frozen

  1. Restart the I/O server
  2. If this does not work restart the computer

I/NET has reached its maximum online event size and FIFO is not working (very rare)

  1. Right Click on the I/O server and select Archive Configuration
  2. Enable Archiving if it is not enabled
  3. Increase the size of the maximum online events
  4. Restart the I/O server
  5. Trigger an Alarm or Event in I/NET
  6. Verify AMT 

Other troubleshooting steps

  1. Force a Lan to reconfigure by changing the station address of the Xenta 527, then changing it back

If AMT still will not function Repeat the above processes using an Event window with no filter.  It is possible messages are being received, just not to the open Window

  1. Close all open AMT windows
  2. Select System>New>Event Window
  3. Click Okay
  4. This opens an Event Window which will display all data coming into AMT
  5. Repeat the above troubleshooting processes

The Controller LAN is having communication issues

  1. Cycle power on one of the Controllers on the Controller Lan to force a Lan Reconfigure

Other solutions for this issue have been documented in these articles:

  • No door transactions coming into AMT: Quick Poll is not enabled.  Typically applies to older sites.
  • Transactions not Updating AMT Window using direct connect: For Direct Connect systems
  • No Transactions or controller Events in AMT: Reliable Tap
  • AMT messages stop after re-installing I/NET: Applies to recently upgraded sites.
Labels (1)
Labels:
  • TAC INET
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  • ChrisAsbury20
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