Issue
Windows authentication is not working with Security Expert once configured.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert Server
- Windows Authentication
Cause
Windows authentication was not installed or configured properly during initial install/setup of Security Expert.
Resolution
- Install the Security Expert Server, and any Security Expert Clients, with the "Enable Windows Authentication" option enabled during the installation process. If this was not initially done at install then it will be required to backup the SecurityExpert and SecurityExpertEvents databases, uninstall Security Expert (installing overtop or repairing install may not work) and then re-install Security Expert with the "Enable Windows Authentication" option enabled. Refer to Determining Security Expert authentication settings after installation to determine the authentication used.
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When Windows Authentication is enabled in the client go to Global (1) and select Operators (2).
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Create a new operator as below:
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Select to add a new operator (1).
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Enter a Name (2). The name does not need to be the same as the operator's username.
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Enter a UserName (3). The username must match the domain name and domain username required to have access to Security Expert. This is in the form of "DomainName\UserName" as shown in the example image.
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Set a Role for this operator (4).
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Enable the "Use Windows Authentication" checkbox (5) and save the changes.
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- Go to Global (1) and select Home (2) and logout of Security Expert.
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On the login page select the "Use Windows Authentication" checkbox (1), set the Server to the Security Expert Server machine name (2). Leave this blank if it is the local machine) and press Log in (3).
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The system should now be logged into Security Expert with the Windows username being used.
If an "Access Denied" is received or another error then confirm the following before contacting Product Support for further help.
- Ensure Security Expert Client and Server were installed with the "Enable Windows Authentication" option enabled. Refer to Determining Security Expert authentication settings after installation to determine the authentication used.
- There is an operator object created in Security Expert with the same domain and user name as the domain user required for login.
- The "Use Windows Authentication" option is enabled on this operator object.
- At the login screen "Use Windows Authentication" is enabled and the Server is set correctly.