Issue
How do you see what authentication settings Security Expert was installed with?
Product Line
EcoStruxure Security Expert
Environment
Client/Server Authentication
Cause
When installing the Security Expert Client/Server three authentication settings for the Client to Server connection can be specified:
To connect to the Security Expert Server using additional software, such as Data Sync or SOAP, the current authentication is needed so the additional software authentication can be set the same. However, if this was not recorded at installation the only way to be 100% sure is to remove and reinstall.
Resolution
Navigate to the existing Security Expert installation folder:
C:\Program Files (x86)\Schneider Electric\Security Expert
Depending on the installed components there will be a file called either:
- SecurityExpertSV.exe.config - where only the Server component is installed
- SecurityExpert.exe.config - where only the Workstation component is installed
Note: both files will be available if the Server and Workstation are installed on the same machine
Either file can be used. Open the file using a text editor such as Notepad to find the current Security Settings used in the original installation. In the example below the authentication setting used was TLS 1.2
As illustrated in the image above the information is between the <netTcpBinding> tags. The image below illustrates the settings for the three possible authentication types. Look for the <security> tags to identify the authentication used: