Issue
EBO can have license violation bar without a known reason.
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Enterprise Server
- Building Operation Enterprise Central
- Building Operation Automation Server
- Building Operation Automation Server Premium
- Building Operation Automation Server Bundled
- Building Operation Edge Server - Standard
Cause
License enforcement is the process of checking whether a software application has a valid license available to it at runtime. If you do not have enough licenses, a license violation occurs. This is accomplished by a license violation bar in WorkStation and WebStation.
Firstly, the license violation will be yellow, and it can be hidden for 8 hours. You can use Hide to hide the License Violation bar for 7 days.
After 7 days, the Hide function is disabled.
After 30 days, the bar turns red.
Resolution
Below information can be collected to help in troubleshooting:
- Refer to the document Part Number Summary and Hardware Software Matrix for software and features that need licenses and note that some feature licenses can be inherited from parent server to child servers.
- Get a screenshot of the License information page in the control panel, make sure to have all content in license information page are shown in the screenshots, ex child servers' status. It can tell which feature needs a license or which child server needs a license, refer to License Information
- Get the License Diagnostics, and entitlement certificates to make sure that required licenses are activated.
- Install the latest CP/hotfix to make sure that the system is not affected by one of the known license related defects,
- Make sure that all EBO servers have correct date and time, incorrect date and time can cause license violation, as explained in: Incorrect Automation Server date and time leads to license violation - Schneider Electric Community
- Check Known issues community.
- Get screenshots for the following:
- In ES, "System/LicenseManager/LicenseStatus/ConnectedASLicenseStatus" will show all connected Automation Servers. Show the license violation tab to know which Automation Server has violation as Automation Server may have violation although license information doesn't show that, ex. if the "Change Control" feature is enabled in an Automation server and ES doesn't have a license for it.
- For parent server and any server that has violation, search in folder "/System/LicenseManager/LicenseStatus". In the object name, write "*" and add columns License Violation, Checked Out License, Available Licenses, Required Licenses, and Installed Licenses. Export the results to XLSX.
- Check license Metadata for the parent server and any servers have license violation, search in folder "/System/LicenseManager/LicensingMetadata". In object name, write "*" and add columns FeatureVersion, FatureName, ProductVersion, EntitlmentID and Activation ID. Export the results to XLSX.
- Get screenshot from FlexNet Publisher web interface, localhost:8888, concurrent tab. Make sure all features are shown in the screenshot, and the entire webpage can be saved instead of taking screenshots. If the server has just started, wait for some minutes till all data is collected.
- Collect the logs and configuration files listed below:
- Log files located in C:\Program Files (x86)\Schneider Electric EcoStruxure\Building Operation x.x\License Server\logs
- Configuration file located in C:\Program Files (x86)\Schneider Electric EcoStruxure\Building Operation x.x\License Server\conf
- Using EBO WorkStation, go to module, '/System/Modules/Trace/Loggers/nsp/nsp.csc/nsp.csc.licensemanager", set trace level to debug, reproduce the issue, if possible. Collect the server logs, then set the module trace level back to "information", refer to Collect logs from an Automation Server - Communities and Collect logs from the Enterprise Server and Enterprise Central - Communities.