Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.
Issue
Log data is not being logged into SQL.
The Reports Server indicates that the database is full.
This view will be shown when logging into the WebReports interface. If this chart is not shown, the PC is not running an Express edition of SQL.
Product Line
EcoStruxure Building Operation
Environment
Reports Server
Cause
In most instances, the data that quickly fills the SQL database are Events. Event data fills the SQL Database and prevents log data from passing to the Reports Server database. If the data has filled within a few days, this would indicate an issue, and contacting your local support is the best option here. The Process below allows the user to stop the reporting agent from passing specific information to the Reports Server.
If the data files are due to the amount of data stored, then an upgrade to the Standard/Full version of SQL is recommended.
Resolution
- Download the latest SBO Reports Agent Config tool from the community.
- Load the Tool onto the Reports Server PC.
- Stop the Reporting Agent Using the Tool
- Press F7 to get to the Advanced Agent Configuration Page
- Change the numEventRecordToRead property to 0. This will prevent future event data from being written to the Reports Server database.
- Press Ok
- Under the Maintenance tab of the tool - there are two options under Events
- Delete future events, alarms, and trends
- Delete events and alarms older than...
- Restart the Reporting Agent
This will stop any further Events from being passed through to the SQL Database.