Issue
When trying to activate an embedded license on a SmartX Server using Device Administrator, the activation fails with the following error message:
Failure (error) received when reclaiming an embedded license on an Automation Server
"Embedded operation: Activate failed: ASEmbeddedAPI internal error: Capability request could not be created."
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Automation Server Premium (AS-P)
- Building Operation Automation Server Bundled (AS-B)
- Building Operation Automation Server (AS)
All of the above v. 3.0 or higher
Cause
The cause of this problem is that the trusted storage, i.e., the embedded license database on the SmartX server, is corrupt. The embedded licensing framework undertakes internal checking and if it determines there is a consistency problem, it will consider the trusted storage to be corrupt. This means that no operations to the trusted storage, such as activating licenses, will succeed. At the time of writing, it is unclear why the consistency problems happen.
In the server log, you may also observe the following error message:
10:08:06: Executing licensing command
10:08:06: Executing embedded operation: Activate ActivationID: ACT-XXXXXXXXXX-XXXXXX-XXXXXXXX
10:08:11: Embedded operation: Activate failed: ASEmbeddedAPI internal error: Capability request could not be created
10:08:11: Licensing command completed
10:08:11: Activating licenses failed
(Real Activation ID replaced with ACT-XXXXXXXXXX-XXXXXX-XXXXXXXX)
Although this process is specific to the "Capability request could not be created" error, similar errors can be corrected by following the steps shown in the resolution. Please attempt all steps before contacting support.
Resolution
Building Operation 2022 v4.0.4 and above
Upgrading to the above versions will now resolve the trusted storage corruption and inhibit license activation.
Building Operation 3.2.X and up to EBO 2022 v4.0.3
Note:
Although this process is specific to the "Capability request could not be created" error, similar errors can be corrected by following the below steps. Please attempt all steps before contacting support.
- Clear trusted storage within the server
- Using Device Administrator select the affected server and Open a PuTTY Console
- An alternative way of connecting to the server is to use WinSCP.
- Use File protocol SCP and the admin user.
- Using Device Administrator select the affected server and Open a PuTTY Console
- When connected, follow the instructions as per the Word Document also attached below
- Warm or Cold Start the AS-P
- If failures still occur, attempt the Offline Activation of Licenses Workflow; The key step is that the license is activated offline and then transferred to the server in two different steps, allowing the license activation process to complete successfully.
- Warm or Cold Start the AS-P
- If there are still failures with either of these options, send a support request through your local support center including the errors seen with each activation attempt.
Building Operation version lower than 3.2.X
- If the embedded license is a Client license, there is no need to activate the license. Install the EBO Hotfix 3.0.3.2001 (CP1) or later. This will remove the enforcement of SmartX server Clients in the licensing system. See also article Embedded WebStaion client license when logging directly into a SmartX server no longer needed.
- Other licenses like SmartDrivers, SNMP, and Personal Dashboards may still need to be activated. Contact your local support center to fix this problem.