Issue
Enterprise Server will not start due to no valid license file error: "nsp.csc.licensemanager No valid Enterprise Server license found. Terminating server."
or Cannot find license file. (Error code: -1)
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Software Administrator
- Building Operation License Administrator
- Building Operation Workstation
Cause
Enterprise Server is not started and states no valid license file is found. License Server is installed on the same computer and has valid license(s).
Similarly, WorkStation may not start even with a License Server installed with a valid license.
If you get error -1, it means that you didn't enter the required @ before the license server address.
Resolution
In general, any licensed Building Operation software (Enterprise Server, WorkStation, Editors) needs to know where the license server is located. That means that the license server path needs to be entered on any PC having licensed Building Operation software installed.
The "License Administrator" part of the license installer can be installed on any PC, and the license server address set using the administrator. The license server itself does not need to be installed on all PC's, but only on the PC hosting e.g. the Enterprise Server.
The IP or DNS name of the PC hosting the license server is entered with an initial @, e.g. if the IP of the license server PC is 1.2.3.4 you enter @1.2.3.4
Checkpoints
- Remember to enter the license server address starting with a @. For example, don't use "localhost" but "@localhost".
- Is your evaluation license current? If not, download from EcoXpert Extranet
- Check that antivirus software is configured to allow the operation of the license server. (refer to SmartStruxure Workstation or editors can't get license when using firewall (errors -15 or -96))
- Reboot the machine where the License Server is running. It has been observed in some cases where the error 'No valid license or Cannot find license file error' appeared after an upgrade that rebooting the machine solves the problem.
- Check to see if there are multiple versions of the License Server installed on the machine. If multiple versions are installed, make sure to only run the highest installed version as a Windows Service. All other License Server and License Administrator software should be uninstalled from the machine.