Issue
Cannot generate a report from Access Expert V2. Getting an error when attempting to generate the report
"Could not load file or assembly Microsoft.ReportViewer.WebForms, Version=11.0.0.0"
Product Line
EcoStrucure Access Expert
Environment
- Version 2
- Report Viewer
- Windows
Cause
The ReportViewer files that are from Feenics's website contain version 11. Microsoft does have older and newer versions of the file (i,e 10 and 12) so there is a potential that these files will not work.
Resolution
To resolve this issue
1. Download the Microsoft Report Viewer (Feenics Training> Web App V2> Miscellaneous Downloads) http://www.feenics.com/Downloads/ReportViewer.zip
2. On the Access Expert application PC (Not the SQL Server PC in a 2 PC system)
Uninstall all versions of Report Viewer and SQLClrTypes from Windows> Control Panel> Programs and Features
3. Stop the Feenics Keep Render Service
4. Unzip the Download files (Report Viewer.msi and SQLClrTypes.msi) and install both of them
5. Restart the Feenics Keep Render Service
Test Reports
6. If they are still not working, reboot the Access Expert PC and test again. If this is still not working, contact your local country support.