Issue
Do IP settings go to defaults when flashing from 4040 to 9640?
Product Line
Andover Continuum
Environment
- bCX9640
- bCX4040
Cause
Have a need to flash a controller from bCX4040 to bCX9640 over a remote connection access. Do not want to have to go to the site to reset IP settings.
Resolution
Using CyberStation v1.93 a bCX4040 was flashed to a bCX 9640 and it did NOT lose its IP info.
Notes:
At the end of the upgrade an error was received: “The uprev could not communicate with the specified controller”. From the webpage it was noted that the IP address had not changed and the upgrade was successful.
It did not come back online in CyberStation. From the webpage, resetting it still did not bring it back online in CyberStation.
Changing the model number in CyberStation to bCX9640 (from bCX4040) to bring it back online was not an option.
The flash upgrade had reset the ACCNetID to 1.
The 4040 was then deleted (Bacnet side first then Infinity side) and a new 9640 was created. The proper ACCNetID was set up in the webpage and the changes committed. It was then online in CyberStation.
Bottom line – IP address never changed. ACCNetID did. The controller never had to be touched during this process so remotely doing this is expected to work. This was only tested using the latest firmware and CyberStation v1.93.
Of course, the best way to do this is on the bench not on a live system.
Please be aware that the model flash change will cause node count and/or xdriver upgrades to be reset if they were added as post-factory-shipment upgrades (via the Repair Dept) since these upgrade UPD files are model specific. See Node or XDriver Upgrade of BCX Inf (9640) to BCX BACnet (4040) or reverse.
Also see Update b3 or i2 OS, changing (converting) a controller, BACnet to Infinet or Infinet to BACnet .