Issue
Unable to create a backup of an I/NET Seven Database using DBCreate, gets a backup failed error.
Product Line
TAC INET
Environment
Windows XP, Windows Vista OS, with SQL 2000, 2003 and 2005.
Cause
Functionality of the host pc and the database seems to be inconsistent.
Resolution
Option 1:
- Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
- Copy INetDb.mdf and INetDb_log.ldf to an alternate locations (located in C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data)
- Restart all SQL Services.
- Launch DBCreate and remove the existing I/NET Seven Database.
- Create a new I/NET Seven Database.
- Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
- Copy the saved INetDb.mdf and INetDb_log.ldf over the newly created files.
- Restart all SQL Services.
- Launch DBCreate and attempt a backup.
Option 2 (If Option 1 does not work)
- Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
- Copy INetDb.mdf and INetDb_log.ldf to an alternate locations (located in C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data)
- Uninstall and Reinstall I/NET Seven.
- Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
- Copy the saved INetDb.mdf and INetDb_log.ldf over the newly created files.
- Restart all SQL Services.
- Launch DBCreate and attempt a backup.
Refer to How to Troubleshoot on DBCreate for more issues about DBCreate.