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How to Troubleshoot on DBCreate

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How to Troubleshoot on DBCreate

Picard Product_Support
‎2018-09-11 05:45 PM

Last Updated: Administrator CraigEl Administrator ‎2022-08-08 06:35 PM

Issue

  1. After installed I/NET, DBCreate will never pop up to create a new database, which will cause I/NET never launches.
  2. Backup and Restore button are greyed out when opening DBCreate, which also will cause I/NET fails to launch.
  3. When restoring database, an error will show up, saying that version is incompatible with this server.
  4. When restoring the database, an access deny error will show up.
  5. Unable to create a backup of an I/NET Seven Database using DBCreate, gets a backup failed error.
  6. When restoring I/NET database backup from another server in DBcreate, it shows an error: Error dropping PRIMARY KEY 'PK_DvrServers': Could not allocate space for object 'sys.sysserefs'.'clust' in database 'InetDb' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

Product Line

EcoStruxure Building Operation, TAC INET

Environment

I/NET

Cause

  1. SQL default instance is not created correctly.
  2. SQL2005 BCM is not installed correctly if SQL2008 is used, or there is a database version mismatch for I/NET.
  3. This is usually caused by restoring new SQL database to old version or under different kind of Operation Systems (like restoring a 64 bit database to a 32bit SQL server).
  4. Windows permissions are not enough to do the restoring
  5. Functionality of the host pc and the database seems to be inconsistent.
  6. If the database size limit is reached, I/NET database will fail to update. The backup of the database will be fine, but when trying to restore onto another computer, it will also fail.

Resolution

  1. If you are using I/NET 2.4x, and already have a named SQL instance on the computer (for example, TAC Vista 5.1.7 or higher has been installed, with a named instance installed called TACVista), I/NET may fail to recognize it, while also fail to create a default instance. Similar kind of warning will pop up during the I/NET installation:
    Under this condition, use your current SQL server installer or browse to /SQLExpress folder of I/NET installation CD, to manually create a new default instance. You can refer to the guide within the /SQLExpress folder about how to create it. As long as the default instance is created, DBCreate will pop up immediately and a new database can be created. If 64 bit Operation System is used, refer to Installing I/NET Seven on a 64-bit operating system for the detailed guide. Also refer to Installation guidelines for installing I/NET and Vista on the same PC for more details about installing I/NET and TAC Vista on one computer.
  2. If SQL 2008 or SQL 2008 R2 is used, be sure to follow the correct steps about how to install them:
    1. I/NET Seven with SQL 2008: I/NET Seven with SQL 2008
    2. Installing I/NET Seven on a 64-bit operating system: Installing I/NET Seven 2.42 or higher on a 64-bit operating system
    3. If SQL 2008 is installed correctly, please refer to Data Base maintenance before performing an upgradeto perform a forced upgrade for the database.
  3. Refer to Incompatible SQL Server Version error when Restoring I/NET Database in DBCreate: Incompatible SQL Server Version error when Restoring I/NET Database in DBCreate
  4. Refer to DBCreate backup access denied using Windows Server 2008 R2 Standard and Microsoft SQL 2008 R2: DBCreate backup access denied using Windows Server 2008 R2 Standard & Microsoft SQL 2008 R2.
  5. Refer to Unable to Create a backup in DBCreate: Unable to Create a backup in DBCreate.
  6. Refer to Fail to Restore the Backup from I/NET with SQL Database Size Limit is Reached: Fail to Restore the Backup from I/NET with SQL Database Size Limit is Reached.
Labels (2)
Labels:
  • EcoStruxure Building Operation
  • TAC INET
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