Issue
Getting an Error 1001 near the end of the EcoStruxure WebReports Installation
Reports not functional from WebReports
Product Line
EcoStruxure Building Operation
Environment
- Web Reports
- SQL 2008 R2
- Windows Server 2008
- Windows Server 2012
Cause
This error is caused when the WebReports installer is unable to reach SQL Server Reporting Services to configure the WebReports Interface
Resolution
- Clean of the Pieces of the failed install. Use the uninstall process listed in the WebReports Reference Guide or Uninstall Process for Web Reports.
- Correct all possible causes of the failed install
- Verify that you can connect to the ES using http from the Reports Server PC
- Verify that you can connect to http://localhost/Reports_SQLInstanceName
- Re-install WebReports.
NOTE: You may be able to correct the issue without having to remove and re-install WebReports.
Possible Issue: The Microsoft Reporting Service SQL databases are not registered
- Check through SQL Management Studio that the 2 databases "ReportServer$instance" and "ReportServer$instanceTempDB" are registered. If not, the SBO Web Reports installed have nowhere to place the report pack files.
- If they are not there, you need to add them through "Reporting Services Configuration Manager". Click "Database" and then "Change Database". Here you can chose to create new databases.
Possible Issue: Insufficient User Access
- Log out of Windows and Log back in using a PC admin account. The account logged in for the installation should have full access to Windows and be a DB admin in the SQL Server.
- Set the User Account Control Settings to Never notify.
Possible Issue: PC Configured as a Domain Server
- In the Server Manager, check that the IIS Role is configured and that there are no Domain Roles assigned to this PC
Possible Issue: Another Application is using a Required SQL function
- Uninstall any application which use SQL on this PC. (The Enterprise Server does not Use SQL)
- As a Best Practice, the Reports Server should be installed on its own, dedicated PC.
Possible Issue: Incorrect Version of SQL Server or Windows Server
- Check the Reports Server Specification Sheet for your build and verify that you are on the Correct Version of Windows and SQL.
Possible Issue: Secure Connection Level set too high
- This issue typically also results in not being able to log into http://localhost/Reports_SQLExpress.
- Log into the Reporting Agent Configuration Manager Application
- Click on the Report Manager URL on the left-hand column
- Click on the HTTP URL
- This will give you the correct URL for your installation of SQL
- If this fails, browse to C:\ProgramFiles\Microsoft SQL Server\MSRS10_50.SQLEXPRESS\Reporting Services\ReportServer (this may vary based on SQL Installation)
- Modify the CONFIG file "rsreportserver"
- Change the Secure ConnectionLevel to "0"
- Save the file and attempt to log into http://localhost/Reports_SQLExpress again.
- For more details on this property see: http://technet.microsoft.com/en-us/library/aa179559(v=sql.80).aspx
Possible Issue: .NET Framework is not operating correctly.
- Download the correct version of .NET framework for your version of EBO (The correct required version can be found on WebHelp Reports Server under EcoStruxure Building Operation Software Requirements)
- Run the installer in "Repair" mode
Possible Issue: The Windows account "appuser" is not created because the default password does not meet password policy requirements
- Temporarily disable password policy on the server and try reinstalling.
- For clarification of the use of 'appuser', refer to the following article, Report Server "appuser" clarification