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Uninstall Process for Web Reports

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Uninstall Process for Web Reports

Picard Product_Support
‎2018-09-07 01:49 AM

Issue

Uninstall Process for Web Reports

Product Line

EcoStruxure Building Operation

Environment

  • SmartStruxure Web Reports Server
  • StruxureWare for Building Operation Web Reports Server

Cause

After a re-install of webreports, certain features will not function if the original version was not completely removed.

Resolution

To uninstall WebReports:

  1. In Windows Control Panel, point to Programs and then select Uninstall a Program.
  2. Right-click StruxureWare Report Pack Installer and then click Uninstall.
  3. Right-click StruxureWare Reporting Agent and then click Uninstall.
  4. Right-click StruxureWare Reports Installation and then click Uninstall.
  5. Right-click StruxureWare WebReports and then click Uninstall.
  6. Right-click StruxureWare WebReports Service and then click Uninstall.
  7. In your Web browser, type the URL for SQL Server Reporting Services Report Manager. If you have installed SQL Server 2008 R2 Express, the URL is http://localhost/reports_sqlexpress
  8. Click Details View.
  9. Select the folders that contain the WebReports reports including Data Sources.
  10. Click Delete.
  11. Click OK.
  12. Click Close.
  13. Open Microsoft SQL Server Management Studio (type SQL in the Start menu Search box).
  14. Expand the Databases folder.
  15. Right-click StruxureWareReportsDB and then click Delete.
  16. In the Delete Object window, select StruxureWareReportsDB.
  17. Select Close existing connections.
  18. Click OK.
  19. Open Internet Information Services (IIS) Manager (type IIS in the Start menu Search box).
  20. In the Connections pane, expand Sites, expand Default Web Site, and then expand SchneiderElectric.
  21. Delete each virtual directory in the specified order:
    - Right-click WebReportsService and then click Remove.
    - Right-click WebReports and then click Remove.
    - Right-click SchneiderElectric and then click Remove.
  22. - In the Connections pane, select Application Pools.
  23. Right-click SchneiderElectric.WebReportsAppPool and then click Remove.
  24. Right-click SchneiderElectric.WebReportsServiceAppPool and then click Remove.
  25. Exit Internet Information Services (IIS) Manager.
  26. In SQL Server Reporting Services Report Manager (see previous steps), click Folder Settings.
  27. Select the NT AUTHORITY\IUSR check box and the [PC NAME] \appuser check box, and then click Delete.
  28. Exit SQL Server Reporting Services Report Manager.
  29. In Windows Control Panel, select System and Security, then select Administrative Tools.
  30. In Computer Management, expand Local Users and Groups and then select Users.
  31. Right-click appuser and click Delete, then follow any further prompts to complete the deletion.
  32. In Microsoft SQL Server Management Studio, expand Security and then expand Logins.
  33. Right-click the appuser account and then click Delete.
  34. In the Delete Object window, select appuser.
  35. Click OK.
  36. Click OK again.
  37. Right-click NT AUTHORITY\IUSR and delete it in the same way as you deleted the previous (appuser) account.
  38. Right-click [PC NAME] \appuser and delete it in the same way as you deleted the previous (appuser) account.
  39. Exit SQL Server Management Studio.
  40. In Windows Explorer, expand Program Files (x86) and then expand Schneider Electric.
  41. Right-click StruxureWare Reports Installation and then click Delete.
  42. Right-click StruxureWareReports and click Delete, then follow any further prompts to complete deletion.
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