Issue
When adding Shadow Schedule in AS, it isn't synchronized with the Lead Schedule in ES. This issue only happens when there is an Exception schedule assigned with another Calendar added to the Lead Schedule in ES.
Error: "cannot verify lead object status"
Product Line
EcoStruxure Building Operation
Environment
- SmartStruxure
- Lead and Shadow
Cause
If a Lead Schedule contains an Exception with another Calendar assigned in ES, and a Shadow Schedule needs to be pointed to this Lead Schedule in AS, both the Shadow Calendar and Shadow Schedule need to be created and pointed to corresponding Lead Calendar and Lead Schedule. If only Shadow Schedule is created, it will fail to update to Lead Schedule, or even wipe the original setting with a blank schedule.
When involving Calendars the following should be considered:
- The only way that the lead and shadow relationship can be maintained where calendars are concerned is where the calendar has the same name and is at THE SAME RELATIVE PATH as it does with respect to the lead schedule. Consider the following examples:
- Example 1 - Lead Schedule is at Root and Shadow Schedule is at root and Referenced Calendar is at root. - under these conditions there is only a need for one Calendar object. The Lead Schedule has an exception that references the calendar at the root and everything works great.
- Example 2 - Lead Schedule and Referenced Calendar are in Folder 1 and Shadow Schedule is in Folder 2. This will not work because the Shadow Schedule is trying to reference a calendar at the same relative path, i.e., in Folder 2, and there is none there.
- Example 3 - Lead Schedule and LEAD Referenced Calendar are in Folder 1 and Shadow Schedule AND SHADOW CALENDAR are in Folder 2. This will work fine.
- In simple terms keep the names and paths within the ES and AS consistent (the same) to avoid issues.
Resolution
Before the steps below, ensure the communication between AS and ES is OK. Refer to Binding between ES and AS or two AS shows Unresolved and Shadow Schedule in the Automation Server is not syncing to the Lead Schedule in the Enterprise Serve....
If the communication is fine, continue to the following steps:
- Create Lead Calendar and Lead Schedule in ES, and assign the Lead Calendar to the Exception of Lead Schedule (Should already done before).
- Create Shadow Calendar and Shadow Schedule in AS, and point them to corresponding Lead Calendar and Lead Schedule in ES.
- Now the Shadow Calendar should be able to synchronized with the Lead Calendar after changes have been made to the Lead Schedule.