Issue
Vista reports fail to save to the server when they are being edited from a remote workstation.
Product Line
TAC Vista
Environment
- Vista
- Microsoft Excel
Cause
When setting up remote workstations on a LAN or WAN, there are certain steps that must be taken. If the proper DCOM settings are not set up on every remote workstation as well as the computer that runs Vista server, there can be authority issues. Vista reports can be created but will not allow values or trends to be saved into the report. In some cases this has generated the error "The RPC Server is unavailable" as seen in Error: The RPC server is unavailable.
Resolution
On ALL remote workstations and the main server:
- Run DCOM Config 1.0.2.2.exe found in Helpful Vista Utilities - Configure DCOM instantly, Register ASP.NET. Either select Server-Workstation or Server-Workstation-Webstation.
On the main server that will be used to run Vista Workstation:
- Run > dcomcnfg
- Expand Component Services
- Open Computers
- Right-click My Computer and choose properties
- Go to COM Security pane
- For Access Permissions and Launch and Activation Permissions choose to edit both Edit Limits... and Edit Default...
- Add users Anonymous and Everyone with Remote Access
- Go back to Component Services and open My Computer
- Open DCOM Config
- Browse for OPCEnum right-click and choose properties
- Go to Security pane
- Change the three options to
- Launch and Activation Permissions -Use Default
- Access Permissions -Use Default
- Configuration Permissions -Customize
- Choose Edit > add Anonymous and Everyone with Remote Access
- Choose Edit > add Anonymous and Everyone with Remote Access
- Go back to DCOM Config and browse for TACOS right-click and choose properties
- Go to Security pane
- Change the three options to
- Launch and Activation Permissions -User Default
- Access Permissions -User Default
- Configuration Permissions -Customize
- Choose Edit > add Anonymous and Everyone with Remote Access