Issue
Getting the error "The RPC server is unavailable" when attempting to write to a Vista Database.
This error can also be shown in the plug-ins output pain as "Error: Failed to access object xxxxxxxxxx."
Product Line
TAC Vista
Environment
- TAC Vista System Plug-in
Cause
- Incorrect DCOM or Firewall settings.
This often occurs when installing a new system or restoring an existing Vista Database to a new PC. - Computer is running out of memory.
Resolution
If it is cause due to computer memory shortage, please restart the TAC Vista Server. If the restart does not solve the issue, please follow the steps below.
- Install the DCOM utility located in Helpful Vista Utilities - Configure DCOM instantly, Register ASP.NET. or manually set the DCOM settings as instructed in the TAC Software Installation
- Unzip and execute the utility.
- If the problem persists and Vista Server is not on the local machine, ensure there is not a Firewall preventing a connection.
If steps above does not resolve the issue, please reinstall TAC Vista software.