Issue
Unable to login to AS directly when using Domain user. It is possible to login to AS directly with "Local" Domain and to the ES with same Domain.
Receive error "Can not continue because server is offline or temporarily unavailable" even though ES is online.
Product Line
EcoStruxure Building Operation
Environment
- Enterprise Server
- Automation Server
- Domain
Cause
AS is unable to communicate with the ES to properly authenticate the Domain user.
If the ES is picking up a WiFi IP address instead of the LAN IP address, this can be the cause. All other communications can still function correctly with the ES but the issue occurs when the AS tries to connect directly to query the Domain, it will be using the wrong IP address.
Resolution
- Changed the order of NIC''s in Windows so that the Local Area Connection was first, confirmed the ES had the correct IP address, confirmed the AS saw the change, and was then able to login to the AS directly using the Domain user. See How to set the Enterprise Server IP address for details on how to ensure you are using the correct IP address.
- Another thing to look out for is that you are using the correct port number for the ES communications as seen from the AS.