Issue
One of the following error messages are displayed.
Internal server error
Server already part of a system
Product Line
EcoStruxure Building Operation
Environment
- Building Operation WorkStation
- Building Operation Server
Cause
Cause #1
The automation server is either not the same version as the enterprise server or it is still connected to a different Enterprise Server. If the AS is still connected to another ES then it must be detached before it can be added underneath a new ES.
Cause #2
In some instances, the User Permissions "System Address" is not added to the user account that is attempting to add the server.
Resolution
If you are given an error that states "Domain: Internal Server Error" then you need to download the same version of firmware to the AS that is installed on the ES.
Resolution #1
In order to detach the automation server, follow these steps:
- Log in to the Automation Server.
- In the system tree pane, right-click on the automation server and go to Advanced > Detach server.
- The Disconnect Automation Server window will open; click yes.
- The Automation Server is now detached and can be added to an Enterprise Server.
Resolution #2
To confirm this is the issue, the simplest resolution is
- Check a current backup using the and verify the number of servers listed under "Reports>Servers" exist or
- Log on using the default admin account and see if these servers exist.
- Detach the server(s), as described above.
If the secondary user still requires permission to add and see ALL servers go to the user and select the Permissions tab shown below:
- Ensure the ES path is selected
- Click on the "Add System" button (identified with the arrow)
- Enable all options to allow read/write, create etc.
- Save these changes and log off and back on with this user to see the changes.
This user should now be able to add/see ALL servers.