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Troubleshooting logon / display issues with the Mobile App Building Operation Technician Tool ("SmartBldgOp")

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Troubleshooting logon / display issues with the Mobile App Building Operation Technician Tool ("SmartBldgOp")

Picard Product_Support
‎2018-09-10 11:27 PM

Last Updated: Kirk Mahmoud_Sayed Kirk ‎2023-07-12 06:50 AM

Issue

  1. Can not logon with the Mobile App Building Operation Technician Tool.  Logon screen appears but app closes after selecting Logon
  2. No objects are displaying in my Custom View folder or other locations 
  3. Can not view or acknowledge alarms
  4. My alarm display colors as set in Workstation are not displaying correctly in the mobile app 

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation Technician Tool 1.0.0 / 1.1.0
  • Building Operation Enterprise Server and SmartX Server 1.9.3 and below

Cause

May be various cause that are not allowing the Mobile App to connect to the server (Enterprise or Automation Servers), including EcoStruxure Web Services (EWS) Configuration Setting, folder names, User permissions and Alarm configuration.  Please review the different options below for assistance.

Resolution

Please note:

Mobile experience to be replaced with EcoStruxure™Building Operation v2.0 WebStation

For further information, please refer to Notice of Withdrawal of the Building Operation Technician Tool

 


When logging into the Technician Tool it times out

This has been seen before and was caused by the Windows Firewall. If you are able to ping back and forth between the enterprise server and iPad/iPhone, then it may be a firewall issue. You can either shut down the Windows Firewall or use Creating Windows Firewall rules to allow StruxureWare Building Operation to communicate on the TCP p... to set up firewall rules. 


Unable to connect to server or "Contact  technical support" message given

When logging in to the Technician Tool, specify the HTTPS port in the SERVER field (EX: 192.168.10.20:446).

 

The mobile app uses the feature from Building Operation StruxureWare call EcoStruxure Web Services, as such a majority of issues can stem from this setting.  If you are having issues logging into the Enterprise Server or Automation Server using the Technician Tool check the following:

  1. Software installed on both the Enterprise and Automation Servers must be 1.3.0.938 or later?
  2. Ensure the EWS Server Configuration settings are enabled in the server.
    1. As a minimum Serve Value and Serve Alarm must be set to true
    2. Browse allows object to browsed if not set, no objects will be displayed
  3. Ensure the user has sufficient permission to log in and MUST be member of the default domain

Values are not displaying in the Custom View folder or other locations

  1. Custom View folder must be located in the root directory of the Enterprise Server
  2. Check the EWS Configuration settings and ensure Browse is set to true - refer to item 2.2 above.
  3. In the EWS Configuration there is a tab labeled "Filter Hardware Folder"; Filters can be assigned By Path or By Object, check that the nominated folder or object has been filtered.

Can not view or acknowledge alarms

  1. In the EWS Configuration settings ensure that the Alarm Acknowledge setting is set to true.
  2. Also check that the Alarm has no additional 'Enforcement', such as Cause / Action - these alarms can only be acknowledge through Workstation.

My alarm display colors as set in Workstation are not displaying correctly in the mobile app

  1. Unfortunately the Alarm colors are hard coded within the Mobile App - this feature may be provided in a future release.  Date for this is currently unknown.
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