Issue
When starting up the Continuum Workstation an error "SmartHeap library out of memory" error is displayed and Continuum does not startup.
Product Line
Andover Continuum
Environment
Continuum Cyberstation
Microsoft Windows
Cause
The PC memory allocated for Cyberstation to use is insufficient for the application and the site's configuration.
There are three known items that can require more memory to be required on Workstation startup.
- EventNotifications. If a very large number of them. The Workstation reads all of them and may require more memory at startup.
- Workstation Programs. Check in the Workstation for many or large Programs.
- Objects in the Root of Continuum. The startup of WS can be very long with a large number of objects in the Root.
Resolution
- Verify that the PC being used for the workstation meets the minimum requirements as defined in the Install.pdf document for the specific Cyberstation version being used. If other applications are to be run on the PC then the RAM size should be increased accordingly.
- If the system StandAlone (Single User) 1.81 or before then verify the database size is below 2Gb, For Version 1.82 and above it can not exceed 4Gb.
- Verify that you have sufficient available memory you have when seeing the error, using task manager.
If the above checks confirm that the basic PC memory is sufficient then the following changes can be made to allow the Cyberstation application further resources, this is often required when a number of Plain English programs are running in a Workstation.
- Shut down Continuum and set the Virtual Memory size Initial to 2048 and Maximum to 4096.
- Using Regedit go to the registry key HKEY_CURRENT_USER\Software\Andover Controls\Continuum\Settings and increase the setting for omscachesize to 5000 decimal. For systems where the Workstation is known to have an extremely heavy workload, this number may be increased up to 9000 in decimals. If using the Elevator Control Module add-on, it may be necessary to set the size to 5000.
Note: For new Continuum or WebClient Workstations, the omscachesize registry key is not created until after the Workstation has first logged in at least once. If you are adding a Workstation to an existing LAN installation with a large ContinuumDB, then the omscachesize may need to be increased right from the start. One way to do this is to:
- Create a new "test" database, see Creating a test database for troubleshooting for more information.
- Connect this Workstation to that test database so that the correct registry keys are created
- Change the omscachesize value as described above
- Restart the PC
- Reconnect to the original production database and start-up Continuum.