Issue
"No license for LonWorks communication" Error when starting Workstation.
Product Line
TAC Vista
Environment
- Windows 2008 Server X64
- TAC Vista 5.1.5
Cause
- Windows Server is member of a domain.
- Configure the TAC Vista Server to run as a service, with a local user set as administrator to logon.
Results in "No license for LonWorks communication" when starting Workstation. If starting the service with a domain user or local system, it works.
Resolution
Windows Security Policy
This may have something to do with UAC (User Account Control) in Windows. The user that launches TAC Vista was already as a local administrator, but it seems that a log out with the user, log in with a local user, and log back in with a domain user is necessary for some policies to be set.
Licensing Registry
The Vista licensing requires registry information on where to find a license file. This registry key is found in the following location:
HKEY_CURRENT_USER\Software\FLEXlm License Manager\TACLIC_LICENSE_FILE
If the user has not been logged in and configured to run Vista software, this key might be missing or misconfigured. Ensure that it has a proper value by launching Vista Workstation or running the TAC License Setup. Log in with the user that will run the TACOS service and run the License Server Setup application to ensure the correct file path is defined in the Registry.
Related Articles:
- "No license for LonWorks communication" with TAC Vista Server LE
- "No license for LonWorks communication" error when using a non LE dongle
- "No license for LonWorks communication" - LonMaker Recovery Folder
- "No license for LonWorks communication" error message in Classic Network
- "No license for LonWorks communication" in Vista Workstation
- TACOS startup delay utility