Issue
Switching from the Demo license to the Entitled License in Vista 5
Product Line
TAC Vista
Environment
TAC Vista 5.X.X
Cause
In most cases the license will begin to work just fine after starting Vista and selecting "Use License Server" upon startup. For unknown reasons, Vista may need to be forced to ask you for a License File Or License Server option when Vista is first started after the license is switched.
Resolution
Unlike the Demo license, the site license must be placed in C:\Program Files\TAC\License Files (or C:\Program Files\Schneider Electric\License Files for TAC Vista 5.1.4 and above) and accessed via the License Server. It is imperative that the license file retains the .lic file extension, which importing to certain Windows environments may append a .txt extension to the filename
The easiest way to force TAC software to use a License server versus pointing directly to the Demo License is to modify a registry setting of the Flexnet Licensing Software.
- Start the Registry Editor from the Command prompt (type "regedit" in the start menu run box) and navigate to HKEY_LOCAL_MACHINE>SOFTWARE>FLEXlm License Manager.
- Modify the TACLIC_LICENSE_FILE string and delete the Value data. By leaving this key empty, the next time you start any TAC software you will be prompted to "Specify the License Server System" or "Specify the License File".
- Start a TAC Software package that requires a license.
- Select "Specify the License Server System" and enter the computer name preceded by an "@" symbol. If the License Server resides on the local machine, "@localhost" can also be used.
Note: In more recent versions of License Server, the "@" symbol is optional. If in doubt, putting it in will work with all versions.
If the changes were successful, the registry entries should appear as follows (in a typical installation). If registry settings are different that the ones below, please contact Product Support Services.
If the above changes were performed but the License fails to read, in some cases the License Server system will not work properly until rebooting the PC.
If unable to read the license use LMtools utility located in the TAC Tools to troubleshoot the issue. If additional assistance is needed for using LMtools, watch the video overview published in Vista 5 Macrovision/Flexnet Licensing: Lmtools diagnostic utility overview.
For help with Vista versions >5.1.7, see License troubleshooting in Vista 5.1.8 or greater