Issue
Error displayed: "Extended logging time synchronization problem. The time on the workstation is less than the time of one or more controller log entries," when Workstation tries to download ExtendedLog data from controllers.
Product Line
Andover Continuum
Environment
- Continuum Workstation (LAN & SU)
- NetController (CX99xx , BCX9640, BCX4xxx, ACX57xx)
- InfinetController (i2xxx & First Generation InfinetControllers)
Cause
Time setting is different between Workstation and Controllers or the time setting is same but the UTC Offset (Time Zone) is wrongfully set between the WS and the Continuum Network object of the controller.
Resolution
Set the correct UTC offset (time zone) in all of the below locations:
- Confirm Cyberstation(s) PC time zone (UTC offset) and Windows regional settings are correct.
- Confirm the SQL Server PC time zone (GMT settings) and Windows regional settings are correct.
- In Continuum, the Workstations Device objects Time tab has the correct time zone setting (be aware this is in minutes, ex. GMT+10 = +600 minutes).
- In Continuum, the Network folder has a setting for the time zone, this needs to be configured to the time zone the controllers are located. If GMT+10 then this gets set to +600.
Note: See Configure Time Zone and UTC Offset settings so that time is synchronized across your system for more detail on the various locations for UTC settings and what these are required for.
Setup Workstation and Controller Time Synchronization:
- Synchronize the time on all Workstations to a common source. See instructions in Cyberstation Installation Guide under "Workstation Time Synchronization."
- Synchronize controller time by creating a Program in one of your Cyberstations (only create on one Cyber). This synchronizes the controllers time to the Workstations time once every hour. There are detailed instructions on this in the Cyberstation Installation Guide (with a sample program) under "Controller Time Synchronization." (Also see Time sync controllers to workstations)