Issue
The Vista Remote workstation cannot request the license fro the vista server with the firewall on. If all the ports are opened the license works fine.
Product Line
TAC Vista
Environment
- Windows 7 32-bit
- Vista 5.1.6
Cause
Even though ports 135 and 27000 to 27009 are open Vista license will not work.
The Vendor Daemon (TACLIC.exe) port is by default not specified, and is chosen by the operating system at run time. However, it is possible to specify the TCP/IP port number the daemon use in the license file.
Windows 7 on some installations does not assign a port for TACLIC.exe causing this error.
Resolution
The solution is to manually setup ports for the operation of the license system.
This can be done by editing the Vista License file.
Open the lic file in a text editor
Here is a sample of a standard license header lines.
Please Do not delete this comment line. SERVER this_host TAC_HL_ID=608806830 VENDOR taclic USE_SERVER
Here are the changes to fix ports for the license system:
#Please Do not delete this comment line. SERVER this_host TAC_HL_ID=608806830 27000 VENDOR taclic port=1700 USE_SERVER
This will setup up the LMGRD to use port 27000 and TACLIC.exe will use port 1700.
See Setting the firewall port 135 for a Vista Server running on Windows 7 for information on how to open ports in Windows 7. You will need to select the ports you have defined in your lic file.