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Unable to discover BACnet devices after changing IP Address on AS or ES

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Unable to discover BACnet devices after changing IP Address on AS or ES

Picard Product_Support
‎2018-09-10 11:31 AM

Last Updated: Administrator CraigEl Administrator ‎2022-08-07 11:53 PM

Issue

Unable to discover BACnet devices from a BACnet interface, discover broadcast address and/or devices are offline after changing IP Address on AS or ES. Bacnet devices are offline after a power cycle or loss of IP connection at the AS or ES.

Product Line

EcoStruxure Building Operation

Environment

StruxureWare Building Operations site using devices configured with BACnet

Cause

Broadcasting on wrong network from either the Automation Server or the Enterprise Server can be a problem. In the example below an AS is broadcasting for a BACnet device (in this case a MNB Controller). In the IP Network for the BACnet Interface, check your settings for Broadcast Address. The key is to ensure your BACnet broadcast address is in the correct range.

 

In this first screen capture, we have a BACnet network interface using the IP Network with a red failure to communicate indicator on the MNB.

In this example, the broadcast is on 192.168.1.255

Resolution

The computer being used as well as the BACnet devices we want to discover and use are in the following IP network and settings:

Changing the broadcast address to match what the BACnet network is using resolves the issue (BBMD and BBDT from Enterprise Server or Automation Server).

Lastly, choose to discover devices

For subnet calculations and how to setup your subnet addresses, several recommended calculator are SuperNet Online or SubnetMask a downloadable program from Solar Winds. 


When the IP Network broadcast address is set incorrectly, a Wireshark capture may reveal that no WHO-IS message is sent out from the SmartStruxure server when a device discovery is attempted.

When in doubt as to whether the 'IP Broadcast Address' is correct, a simple test is to set the IP Broadcast address to 255.255.255.255, doing so will instruct the SmartStruxure server to broadcast on ALL subnets, if the problem was caused by an incorrect broadcast address it will be resolved but care must be taken not to leave the default address set to 255.255.255.255 as this will cause unnecessary traffic on all sub-nets, instead, review your calculations for what the appropriate broadcast address should be and set it appropriately.


Key Concept: The AS will retain the Broadcast address, and if moved to a new Subnet, the old Broadcast address must be updated. One can do either of the following: 

  1. Edit the IP Broadcast Address Setting 
  2. Delete the BACnet Interface and recreate in the new Subnet
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