Issue
Instructions are needed to configure the new SMTP configuration.
Product Line
Andover Continuum
Environment
- Continuum
- Non-Microsoft Exchange/Outlook SMTP Email
Cause
Configuration for the SMTP Configuration for email alarming in Continuum 2.00 through 2.03
Resolution
In Cyberstation 2.0 and above, you no longer need Microsoft Outlook and Exchange to send email alarm notifications. Other SMTP servers can be used on the network and other email clients can be used also to send email alarm notifications directly to an intended recipient.
Note:
Public SMTP servers such as Gmail SMTP and Yahoo SMTP do not currently work with this solution as they require SSL or certain unsupported port combinations. The connections these servers establish cause connection issues within the SMTP application. Private SMTP (In-house) servers can be set up and used.
Steps to Configure SMTP Email Alarming
- Open and Event Notification
- Navigate to the Actions Tab
Select which events to receive email alarms
- Select the Delivery Tab
- Click the Add Recipient button to open the recipient configuration
- Browse for the recipient Cyberstation by click the ellipsis
- Select the recipient Cyberstation
- Click the Add Recipient button to open the recipient configuration
- Select the SMTP Configuration button in the Recipient Configuration window
- Fill in the Server Configuration fields in the SMTP Configuration window
- Specify the SMTP Server address, port and login information
- Fill in the Email Configuration
Specify the sender's email address - this is the email address the email will be sent from and it is also the email address that failed emails will be sent to
Type in a Subject line if needed or the default Continuum email subject line will be used
- Alarm Option Settings - Fill in the RetryCount and Retry Time fields
Retry Count - once you pass this value the email is dropped. The maximum Retry Count is 10
Retry Time - field is in minutes. The maximum is 1440 minutes (24 hours)
- Specify the SMTP Server address, port and login information
- Adding an email address to the recipient list
- Click the Display Master List to open the SMTP Master Email Configuration Dialog
- Place a check in the check box to add an email address from the existing Master List to the Event Notification's recipient list and then click OK
- Click the Display Master List to open the SMTP Master Email Configuration Dialog
- Adding or deleting email addresses from the Master Email list
- Open the SMTPMasterEmail Event Notification in the templates folder
- In the opened SMTPMasterEmail Event Notification click the Display Master List button
- Click the Add Recipient or Delete Recipient button depending on what is needed
- After selecting Add Recipient supply the email address in the recipient field and click Add Recipient
- After selecting Delete Recipient, select the address to highlight it and then click the Delete Recipient button. Multiple Selection is supported
- To deliver email notifications to the added email address, select the check box next to it
- Open the SMTPMasterEmail Event Notification in the templates folder
- Testing to ensure email address recipients receive emails
- Select the address you wish to test and click the Test Selected button
- Successful email to SMTP Server test will display a pop-up
- Failed email to SMTP server test will display a pop-up to the Sender's email address
- Final address configuration
- Select the address you wish to test and click the Test Selected button
- Recipients Configuration Options
- Place a checkmark next to the option needed Ex. Primary or Backup SMTP Email
- A checkmark next to Repeat. Repeat will function as if it were an Outlook email alarm and send until the alarm is acknowledged.
Known issues:
In order for BACnet controllers to use the new SMTP feature, the following hotfix from the following link is needed.
CyberStation v2.00 (Only) SMTP Emailing & BACnet Alarms - Hotfix
2.03 contains the hotfix listed above
For additional information, see the Cyberstation Help, search for SMTP.