Issue
When attempting a login from a Security Expert client PC, it generates a "Network SSPI error" when using Windows Authentication and the machine name.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert 4.3.285.21
- Multiple PC Security Expert Installation using Windows Authentication
Cause
The Network SSPI error is generated at the Client PC Login because of how Security Expert implements RFC1034 which stipulates how machine names are used for DNS.
Resolution
1. Place a period at the end of the Security Expert Server machine while logging into the client only Security Expert PC
Example:
- Using "WIN-B0DOGEHESMN" as the server name will not work
- Using "WIN-B0DOGEHESMN." will work
- Notice this works because of the "." at the end
Here is a graphical example of logging in with the correct server name by adding the "."
2. The other workaround would be to use the IP address of the server instead of the fully qualified domain name (FQDN).
*Note* IT departments typically prefer the use of the FQDN name