Issue
What is the procedure for moving the Access Expert DB to another hard drive on the host machine.
Product Line
Access Expert
Environment
- Access Expert Premise Software v3
- MongoDB
Cause
There is no longer enough space on C:. The database must be moved to another drive.
Resolution
- Take a backup of the MongoDB database
- Ensure MongoDB Service is running
- Connect to MongoDB via Command Prompt run as an administrator
- Use the cd command to change Command Prompt to the directory where Mongo is installed Example "cd C:\Program Files\MongoDB\Server\3.6\bin"
- Type Mongo and press enter
- Type "show dbs" and press enter to show a list of the databases
- Open a second Command Prompt session run as administrator
- Use the cd command to change the file path to where you want to store the backup Example "cd C:\Data"
- Type Mongodump and press enter to start the backup process
- Once the backup is completed, stop both the Mongo DB and the Feenics Keep Mercury Services
- Cut and paste the Data directory from C:\Data to drive you are moving the database to. Example D:\ root directory
- Update the MongoDB config file in C:\Program Files\Mongo\Server\3.x\MongoDB.config with the new drive path to the database (this should be as simple as changing the c to d if you moved it to the d drive) for both the logs and the database lines
- Save the config file
- Start the MongoDB Service
- Start the Feenics Keep Mercury Service
- Log in to Access Expert to ensure the migration was successful