Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.
Issue
Upgrading the MPMs firmware through the boot loader was unsuccessful. 10.50.80.2 is pingable, but not the default IP 10.50.80.3. The LED's keep blinking in tandem (alternating one after the other), even after having the MPM powered over 10 seconds.
Product Line
EcoStruxure Building Expert
Environment
SmartStruxure Lite Multi-Purpose Manager
Cause
This can be triggered by multiple events:
- MPM was interrupted (powered off) while the firmware was still being upgraded.
- Database does not exist; MPM was formatted and does not have firmware installed.
- Database is corrupt (for any reason)
Resolution
It is strongly recommended that a firmware upgrade be done via the "File Manager" tab in Building Expert. However, if this is not possible, an upgrade can be performed through the bootloader using the following steps:
1 - At the top left part of the screen, make sure "Status" says "Connected".
2 - Format the SD card clicking on the "Submit" button next to "File System Format". "Format Done" will be displayed next to the button once the format has been completed
3 - Click on the "Browse" button and Navigate to the Firmware_update_V2.XX.bp" on your computer then click on "Submit Query".
4 - The previous step will upload the firmware file to the MPM's SD card. Once the file has been transferred, the following message will appear:
or
5 - The MPM Must be kept powered-up for at least 15 minutes in order to allow the MPM some time to unpack the firmware file. The best way to determine whether the MPM is back online is to ping its IP address using a "Command Prompt" window.
6 - Once the MPM replies to the ping, Building Expert can be accessible though 10.50.80.3
If the above solution does not work; meaning that every time a new firmware is pushed to the MPM, the MPM keeps coming back to the bootloader, contact technical support