Issue
MFC errors when starting or running Cyberstation or Webclient
Product Line
Andover Continuum
Environment
- Windows XP
- Windows Vista
- Windows 7
- Windows Server 2003
- Windows Server 2008
- Windows 10
- Windows Server 2012
Cause
Microsoft Function Class (MFC) errors are typically caused by missing, damaged or altered files that an application is looking for and is having problems using.
Resolution
There can be a number of reason why MFC errors are being received. Here are a few causes related to Cyberstation startup.
- Check the Continuum compatibility matrix. If you are using a version of Windows Operating System that has not been qualified for a specific version (i.e. Windows XP SP2 with 1.93) then this can cause MFC errors.
- Viruses and Malware can also affect MFC files. Be sure to run both types of scans on Cyberstation, but this should be done after the Cyberstation or Webclient PC has been installed. If these types of products are active during an install, they can flag some of the files that would normally get installed as suspect and cause problems with the operation of Cyberstation even if it appeared that the installation was successful. Removing Continuum, rebooting, running scans and then disabling the active scans at the time of the Cyberstation install will often resolve these issues.
- Windows XP, Vista and Windows7 have restore points that you can sometimes go back to in order to restore to a point earlier where the MFC errors were not happening.
- As a last resort, you may need to reformat the hard drive on the PC, reinstall the Windows Operating System including the appropriate service packs and hotfixes and then install Cyberstation or Webclient.
Links to other MFC related articles: