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Log in to Security Expert Web Client and immediately being logged out or seeing SOAP error

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Log in to Security Expert Web Client and immediately being logged out or seeing SOAP error

Picard Product_Support
‎2018-09-10 12:38 PM

Last Updated: Kirk AdamSteele Kirk ‎2022-01-31 08:21 PM

Issue

Scenario 1

Attempting to log in to Web Client you are presented with an error message "Error - SOAP connection failed".

SOAP-ERROR: Parsing Schema: can't import schema from

 

Scenario 2

Upon successfully logging in to Web Client you are presented with "Thank you for logging in" and then immediately presented with another message saying "Log out successful".

 

This continues in a circuit until it may allow you in but displays a partially populated page with no data showing.

Product Line

EcoStruxure Security Expert

Environment

  • Security Expert Server
  • Security Expert Web Client

 

Cause

The option "Use HTTPS to communicate with SOAP service" was enabled in the Web Client Installation Wizard and antivirus was dropping the connection because of this.
 

Resolution

  1. Uninstall and re-install Web Client without the  "Use HTTPS to communicate with SOAP service" enabled or
  2. Browse to the soap.connect.php located at C:\inetpub\wwwroot\SecurityExpertWebClient\include. Edit it using e.g. Notepad and change HTTPS to HTTP and change the port to 8030 so the Web Client uses HTTP to communicate with the SOAP service.
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