Issue
Not possible to get a Xenta Server / 911 online in TAC Vista.
It is possible to ping it and connect to it via a Web browser using ports 443, 80, and Port 1068 is open, but it is not possible to get online in Vista.
Product Line
TAC Vista Server
Environment
- TAC Vista
- TAC Xenta 911
- TAC Xenta Server
Cause
The problem, in this case, was that another Vista server was connected to the Xenta Server / 911.
This could have been from a technician or the customer who started Vista with this database loaded and had the device online in their Database.
The Xenta Server / 911 will only communicate with one Vista Server at a time and will close the connection if another Vista tries to communicate with it.
Using Wireshark it is possible to monitor this scenario as shown below:
- Packet number 57439: Vista is trying to establish communication with the Xenta Server or 911( sending an SYN).
- Packet number 57440: The Xenta sends an acknowledgment on the SYN from Vista, but with the window size set to zero, this is because the Xenta can't buffer information as a computer does.
- Packet number 57441: Vista sends an acknowledgment on the message from the Xenta
- Packet number 57448: The Xenta sets the correct window size.
- Packet number 57449: Vista starts to communicate
- Packet number 57452: The Xenta closes the communication to the Vista server
Resolution
Ensure only one Vista server is started when the Xenta server / 911 is included in the database.