Issue
It is normal for a BACnet network port's Poll Service 'Busy Time' property to be greater than 100%?
Eg:
Product Line
I/A Series
Environment
G3 BACnet
Cause
The Poll Service is a common component for typical field bus drivers including BACnet.
The Niagara Ax Drivers Guide defines the Poll Service's Busy Time property as:
Displays a percentage of time spent by the poll thread actually polling points, across all poll buckets. Includes (in parentheses) a ratio of “(time spent polling/total time since statistics were restarted)”. Given a small amount of time is spent transitioning between poll buckets, and with the thread sleeping to evenly space out polling messages, it is unlikely to ever see Busy Time reach exactly 100%. However, any percentage above 95% indicates that the poll thread is basically spending all of its time actually polling.
Resolution
In the case of the Poll Service for a BACnet network port, because two threads are used for polling, it is possible to see a Busy Time approaching 200%. In this case, divide the Busy Time in half to get an average busy time for each thread.