Issue
What is the procedure on transferring Continuum from one PC to another PC?
Product Line
Andover Continuum
Environment
- CyberStation
- SQL
Cause
Workstation hardware needs to be upgraded or replaced altogether
Resolution
Collect information from the existing machine
- Collect all IP address, DNS server and Windows Server IP information from the existing workstation.
- Run Continuum Database Initialization on the existing machine.
- Select Workstation and record the following information.
- Workstation Name
- Folder Name
- Device Node ID
- Network ID
- Data Source Name
- Database Name
- User Login ID
- Server Name.
- Verify that correct Database Passwords are known for both Andover97 user and sa accounts
- Start Continuum and run PinPoint.
- From the View menu select Options
- Record the folder path indicated under Graphics (Pin Files) and archive these files.
- Record the folder path indicated under Background and archive these files.
- If any customization has been done to the menu pages (i.e. hot spot) then the User Profile folder( C:\Program File\Continuum\UserProfile) should also be archived.
- Backup the Continuum Database
- Move the database backup and the contents of the archived folders described above to a secure external drive or a network folder (not on the workstation itself).
Install CyberStation on the new machine
- Before removing the existing machine from the network, start the new Workstation without connecting it to the network.
- Configure the IP Address, DNS server and Windows Server IP address collected from the existing machine.
- Install CyberStation on the new Workstation PC Note: Do not forget to disable all Virus Protection and Firewalls.
- When prompted run Database Initialization
- Use the information collected on the existing machine to initialize the StandAlone Database.
- Use the information collected on the existing machine to initialize the WorkStation.
- Start Continuum and verify that the CyberStation operates normally.
Copy data collected from the existing workstation onto the new workstation.
- Copy Database backup file to the Backup folder under C:\Program Files\Microsoft SQL Server\
- Copy contents of the archived Graphics folder to the same folder on the new workstation PC.
- Copy contents of the archived Background folder to the same folder on the new workstation PC.
- Copy contents of the archived User Profile folder to the same folder on the new workstation PC.
- Run PinPoint
- From the View Menu select Options
- Under Graphics (Pin Files) enter the folder path to where the Graphics files have just been copied (see above).
- Under Background enter the folder path to where the background image files (see above).
- Select the Check button and verify that a failure notice (a red "X") does not appear beside any item.
- Close PinPoint
Restore the Continuum Database.
- On the new workstation, run SQL Server Management Studio Express.
- Navigate to the Continuum Database.
- Right click on the Continuum Database, select Restore
- Browse to the folder where the existing Database backup file was copied to.
- When the restore has completed successfully. Change the DB Owner:
- Right clicking on the Continuum database
- Selecting new query.
- In the query window type SP_ChangeDBOwner Andover97
- From the tool bar select Execute.
- The result window should return............Command(s) completed successfully
- Reset the passwords for Andover97 and SA
- Open Security from the main tree,
- Select Logins.
- Right click on Andover97 and select properties
- enter and retype new strong password password, retype the correct password.
- Repeat for SA password.
- Now restart the PC.
- Run Database Initialization
- Under StandAlone, update the database.
- Re-Launch Continuum CyberStation and verify that CyberStation is working properly.
- Shut down the new workstation.
Swap the workstations
- Shutdown the existing workstation and remove it from the network.
- Connect the new workstation to the network
- Start the computer.
- Launch Continuum and verify all functions are operating as expected.