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Gather Continuum Controller error logs if requested by Product Support for troubleshooting

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Gather Continuum Controller error logs if requested by Product Support for troubleshooting

Picard Product_Support
‎2018-09-07 01:32 AM

Last Updated: Administrator CraigEl Administrator ‎2022-08-08 03:16 AM

Issue

Controller Error Logs - How to gather Continuum Controller error logs if requested by Product Support for troubleshooting.

Product Line

Andover Continuum

Environment

  • BCX
  • CX 
  • CMX
  • 9680
  • 9900
  • i2
  • b3
  • 9702
  • Controller Error Log
  • Gerry Log

Cause

Troubleshooting controllers often time requires obtaining an error log from the controller

Resolution

The controller error logs contain useful diagnostic information when it is necessary to troubleshoot a controller or system problem. Much of what is logged are normal system operations that may assist an engineer in diagnosing a problem in the field.

To get the error logs from various controllers follow the procedures below:

NetControllers - 99xx 

  • Dumb terminal in using HyperTerminal
  • Sign into the NetController
  • Press V then E and press Enter over the NetController you are attached to
  • Press F2
  • Hit Alt + Print screen and paste into a Word doc
  • Arrow down to single space or Ctrl+D to page down
  • Hit Alt + Print screen and paste into a Word doc
  • Repeat this process until you are at the end of the errors (up to 200)
  • F4 Exits the error log
  • See the CX Controllers Programmer’s Guide for all terminal keystrokes
  • Email the file to Product Support Services
     

BCX/i2/B3 Controllers

CX9680/ACX5720/ACX5740/9702 Controllers

Note: You can not retrieve errors from NetController I (CX9900) using this tool

  • Controller Error Log Tool
  • Navigate to C:\Program Files\Continuum
  • Double click on ControllerErrorLogTool.exe to open (This will do an install the first time)
  • Note: The ErrorLogTool.exe is an older version of this utility and will work, but gives less information and does not contain the error lookup feature.
  • Enter in the BCX or master CX IP
  • Transport type = UDP or TCP depending on controller configuration
  • CX Enode ID = AccNetId from the main CX editor
  • Select Continuum in the Mode area, top right

If the controller is a field device then enter the following:

  • CX infinet port = Select the one you want to report on
  • Infinet Node ID = port number of the i2 device you want the error log out of

Once all the above required entries have been made:

  • Click Get Log and the page will populate with any errors
  • Once this runs, select SaveAs and name the file
  • Email the file to Product Support Services

Suppliment - To gather error logs from Continuum controllers transisioned to StuxureWare please see How to pull the error log from a b3 or Infinet controller in SmartStruxure.

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