Issue
Unable to connect to Access Expert as the Feenics Mercury Service stops and will not restart after a system reboot.
Product Line
Access Expert
Environment
Access Expert Premise Software (AX) v3
Cause
If the Mercury service is failing to start the most common issues are:
- Service Administrator password was changed
- Feenics API is not running
- The OS (Windows) may still be performing some background activity that might slow down essential system functionalities
Resolution
Service Administrator password was changed:
- Update the password within these configuration files to match the new admin password
- c:\program files (x86)\feenics\web api\settings.conf
- c:\program files (x86)\feenics\mercury service\settings.conf
Feenics API not running:
- Check the API by opening the Internet Information Services and checking to make sure the Feenics website is running.
- Make sure the default site is not running.
- You can also check the bindings on the website
- Port 80 and binding of '*'
The OS (Windows) may still be performing some background activity that might slow down essential system functionalities:
- Open Windows Registry: Start -> Run -> regedit.exe
- File --> Export --> make a backup of the current registry
- Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\
- Right-click on the right page ---> New ---> DWORD
- call the new DWORD "AutoStartDelay"
- Set AutoStartDelay in milliseconds (decimal). E.G. 240000 is 240 seconds.