Issue
The error "Failed to Invoke the Security Expert Suprema Component" is seen when attempting to register/enroll a user's biometric credential at a Security Expert Client Only machine.
When doing a registration/enrollment from the Security Expert Server this error is not seen and the registration is successful.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert
- Suprema Biometric Reader
Cause
The Suprema.dll has not been properly registered on the local machine.
Resolution
First check in C:\Program Files (x86)\Schneider Electric\Security Expert folder and confirm that the three files Suprema.dll, BS_SDK.dll, and BS_SDK_V2.dll are all present. If they are not you will need to copy them over from a working installation of Security Expert Server Installation.
Now run the below commands via an Administrator authenticated command prompt session:
For 64-bit machines
- cd C:\Windows\SysWOW64
- regsvr32.exe “C:\Program Files (x86)\Schneider Electric\Security Expert\Suprema.dll”
For 32-bit machines
- regsvr32.exe “C:\Program Files\Schneider Electric\Security Expert\Suprema.dll”
You should get a pop-up saying the .dll was registered successfully.
Close and re-open the Security Expert client and re-test enrolling a user's fingerprint.