Issue
When launching a Access Expert on a Premise install, an error "Unable to retrieve license. Please notify your Keep service provider" when trying to log on to the instance.
Product Line
Access Expert
Environment
- Access Expert
- Wondows 7, SQL 2012
- SQl 2014
Cause
Keep does not have access to the database for license information.
Resolution
Install SQL Studio and give NT AUTHORITY\SYSTEM sysadmin rights. The following captures shows where to go to enable this in SQL.
- Connect to SQL, go to the Security Folder and expand it, select the Logins Folder and expand that then select the NT Authority
- When the tab opens select the Server Roles, then check the box for sysadmin.