Issue
Downloads to some, or all, controllers are not working. Controllers are online to Security Expert but do not receive updates to Users or other changes and forcing a download does not work.
Product Line
EcoStruxure Security Expert
Environment
Security Expert
Cause
One of the Controllers download files has become corrupt.
Resolution
- On the Security Expert Server browse to ..\ProgramData\Schneider Electric\SecurityExpert\Download.
- Review the Controller .dat files, there is one file for each Controller Id in the Database. Check if any of these files have a 0 bytes file size.
- Shut down Security Expert.
- Shut down the Security Expert Download Service.
- Delete each of the .dat files that does have a 0 bytes file size. These will be automatically recreated from the data in the Database.
- Start the Security Expert Download Service.
- Start up and login to Security Expert. Attempt to perform a forced download to the controllers and review the Download Server Diagnostics Window to confirm the controller has been downloaded and .dat file created.