Issue
Instructions are required, on how to set up and troubleshoot a Contact ID Reporting Service.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert Client
- SP-C-WEB
- Contact ID Reporting Service
Cause
Basic information on configuring reporting services is documented in the Security Expert Operator Manual and SP-C-WEB Programming Reference but these do not contain practical steps on configuring this specifically for Contact ID reporting.
Resolution
The Contact ID Service is used to send Alarms, Tests, and Events using Contact ID reporting to a 3rd Party monitoring station capable of receiving the Contact ID format.
The following steps can be used to configure a basic setup of Contact ID.
Note that a modem will be required and modem events can be logged in the events window for troubleshooting.
1. Go to Programming | Phone Numbers. Add your phone numbers, usually primary and backup.
2. Go to Programming | Services. Add a new service, set Service Type to ContactID.
Set Service Mode to 1 - Start With controller OS.
3. Set the Client code and select the previously created phone number
4. Select required report options.
Log Modem Events to Event Buffer option will log all events. Only use this for troubleshooting.
5. Go to Programming | Areas and assign the Service to required Areas
6. Go back to Programming | Services. Right-click the Service record, and select Start Service.
- Without doing this the service will not be running.
- It needs to be manually started the first time.
- Check the controller Health Status to see the status of your service if it is started or stopped.
When done configuring your Services, Inputs, and Areas. Select Reports | Central Station Report.
- Select the Reporting Service and the output directory to generate the file.
- Click Generate and a CSV and HTML file will be generated.
- This report can be provided to the central station for their database.
- The HTML version is the easiest to read.
Further details on the Contact ID reporting format and outlines of the reporting and mapping options can be found in the AN 316 Security Expert - Contact ID Reporting in Security Expert and SP-CWEB - Integration Guide application note.
For Details of creating Test Reports for Reporting Services see KB Article :
Creating a Trouble Input for Periodic Testing of a Reporting Service such as Contact ID