Issue
The Enterprise Server service keeps stopping, and Windows restarts it right away. This is preventing WorkStation or WebStation from logging on.
When viewing the Building Operation Software Administrator, the "Start Service" option is greyed out, and the server status is Stopped.
Product Line
EcoStruxre Building Operation
Environment
- Building Operation Software Administrator
- Building Operation Enterprise Server
- Building Operation Enterprise Central
- Building Operation Workstation
Cause
The Enterprise Server or Central service uses TCP port 80 by default. If another service on the PC is using port 80 (e.g., Internet Information Services), this will cause the service to stop and re-start constantly.
Resolution
Two options:
- Stop the conflicting service from running (e.g., IIS, Dropbox, Skype)
- Change the HTTP or HTTPS port in Enterprise Server or Enterprise Central to a unique port (e.g., 8080)
- To change the ports, open Software Administrator and stop the server if it is not already. Then the port fields will no longer be grayed out, and they can be changed. Finally, restart the server. Refer to: Configuring Server Port Settings
Note: Once the port has been changed to a unique one, this must be specified when logging into WorkStation, as seen below.