Issue
- How can I troubleshoot a communication issue with the Modbus protocol
- Is there a log available within the AS or ES that shows the Modbus communication between Modbus devices
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Workstation
- Building Operation Automation Server
- Building Operation Enterprise Server
Cause
When troubleshooting Modbus issues in an AS or ES it can be helpful to see the communication between devices to help identify this issue. The trace log within both server types is available and is configured as described below in the resolution.
Resolution
- Open Workstation and navigate to [AS/ES name]/System/Modules/Trace/Loggers/nsp/nsp.pin.
- Right-click "nsp.pin.modbus" and choose Properties.
- Under Level, change from "Information" to "Trace", then click ok.
- Let it run a few minutes. If there are some user input needed to recreate the Modbus issue, then perform these steps now.
- Retrieve the log by right-clicking [AS/ES name]/System/Modules/Trace/TraceSettings and choose Trace settings->Get trace log.
- Save the log file.
- A useful tool available on the Community, the Modbus decoder can be used to assist in viewing/debugging the Modbus trace log file information saved in the previous step.
- Once debugging is complete remember to change log level back to "Information" (reverse of step 3).
Note: If the ES or AS is reset, i.e. cold started or warm started, the log level will return to 'Information', so if further increased logging is required, the procedure will need to be repeated.
Note2: From v6 (2024), adding the trace below can be helpful for Modbus RTU /[ASName]/System/Modules/Trace/Loggers/nsp/nsp.pin/nsp.pin.sport/nsp.pin.sport.DeviceRS485
Here is a video showing the above process.