Issue
Active alarms are appear stuck in the alarm viewer for objects that are no longer in alarm.
Alarm notifications will not clear from Active Alarm View.
How can obsolete alarms be removed from the Active Alarm View
Product Line
Andover Continuum
Environment
- CyberStation
- WebClient
Cause
When a Return to Normal (RtoN) notification is reported by a controller, if Cyberstation is unable to receive the notification due to a loss of communication, the status of the alarm notification will not be updated and the alarm will continue to be displayed as though it were active even though the point alarm state is now inactive.
Resolution
Method 1
- Disable the object and change it's value so that a new alarm is induced.
- Refresh the object editor until it indicates that the alarm state is active.
- Enable the object so that it returns to a normal value.
- If necessary, acknowledge the alarm so that it can be removed from the alarm list.
Method 2
- Backup the Continuum Database.
- Edit the object to confirm that it is no longer in an active alarm state.
- From the Root/ListView folder, open the Alarms_AllActive Listview.
- Locate the alarm entry associated with the object.
- Right click on the line and select Delete.
- Restart Cyberstation to update the Active Alarm View from the alarm log.