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Access Expert LDAP integration deactivating cardholders

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Access Expert LDAP integration deactivating cardholders

Admiral Alan_Wood Admiral
‎2024-12-18 09:37 AM

on ‎2024-12-18 09:37 AM

 

Issue

Cardholders are getting automatically changed from Active to Inactive (deactivated).
When the LDAP/AD integration is configured to map the Active Directory attribute UserAccountControl to Card Status in Access Expert; records that have useraccountcontrol = 512 (normal active account) are getting their cards deactivated. These records should NOT be deactivated.

 

An LDAP query mapped to UserAccountControl

LDAP Query UserAccountControlAttribute.png

Card(s) showing Inactive in Access Expert

Cardholder Inactive.png

 

Event History record showing the date and time the cardholder record was set to Inactive by LDAP

EventHistoryRecordShowingDe-Activation.png

Product Line

EcoStruxure Access Expert

Environment

  • Access Expert Hosted V3
  • Active Directory

Cause

A version of the LDAP service less than 24.2.1

Resolution

  1. Manually set the cardholder to Active as a workaround
  2. Ensure the LDAP service installed is greater than version 24.2.1.

See the following link to a KB article showing how to "Identify which LDAP service is currently installed" : https://community.se.com/t5/Building-Automation-Knowledge/Identifying-which-Access-Expert-LDAP-integ... 

 

If the version installed is older than 24.2.1, perform the following steps:

  1. Uninstall LDAP from Windows Programs and Features
  2. Navigate to C:\ProgramData\Feenics_LDAP and delete the .dat file
  3. Restart the PC
  4. Install an updated version of LDAP from Feenic's web site:
    https://s3.amazonaws.com/download.feenics.com/ldap/Feenics.Keep.Installer.ActiveDirectory.msi 

Test to ensure the issue has been resolved with the updated LDAP service

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