Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.
Issue
After an uninstall of I/NET Seven and MS SQL, you might verify in the Windows Registry that all the items were deleted.
Having issues installing I/NET what can I look for.
Product Line
TAC INET
Environment
I/NET all 2.4X versions
Cause
In some cases when re-installing, installing I/NET after a failed attempt or upgrading I/NET you may want to start fresh. After an uninstall of INET Seven and MSDE if items remain in the registry they will cause issues with future installations.
Resolution
- Go to the bottom Task Bar and choose the “Start” button.
- Select the “Run” option and enter “Regedit”
- Once in the Windows registry go to “HKEY_CURRENT_USER, if the “CSI” entry is present delete this entry
- While still in the HKEY_CURRENT_USER look in the Microsoft File Folder for any “SQL” entries and remove them if they are present.
- Minimize the HKEY_CURRENT_USER folder and open up the HKEY_LOCAL_MACHINE File Folder, if the “CSI” entry is present delete this entry.
- While still in the HKEY_LOCAL_MACHINE, go to the Microsoft File Folder and look for any “SQL” entries. If you find any delete then from this file folder.
Caution: Before editing the SQL registry items you should ensure that no other software using SQL is still installed - all software that is installed should be uninstalled prior to modifying any registry entries.
See also, MSDE and Windows 7.