Issue
Loading I/NET on a PC that has full SQL and the Password is not known.
Environment
- I/NET
- Full SQL installation
Cause
If installing I/NET on a PC that has full SQL, MSDE does not get loaded and there is a conflict with the “sa” Password or an existing instance of SQL.
Resolution
Caution: Before proceeding with the following steps, call Product Support for an SQL SP script to re-attach the database files.
- Go into “C:\Program Files\Microsoft SQL Server\MSSQL\Data” and copy the InetDb.mdf and InetDb_log.ldf files to a location outside SQLs directories.
- Go to control panel & select the Add\remove program.
- Select the Microsoft SQL Desktop Engine program and remove it.
- Open Windows explorer again and go to C:\Program Files\Microsoft SQL Server file folder
- Highlight the Microsoft SQL Server file folder and delete it.
- IMPORTANT, go into the recycle bin and delete the Microsoft SQL folder from the BIN.
- Reboot the PC, and then place the I/NET CD into the PC to launch the installation.
- MSDE will install first using the “sa” password followed by I/NET.
- Once installed, verify that I/Net comes up and functions properly.
- Reload full SQL and select the upgrade radio button when prompted.
- Once it gets loaded, verify that it is functioning properly with all other applications.
- Copy the InetDb.mdf and InetDb_log.ldf files back to their original location (C:\Program Files\Microsoft SQL Server\MSSQL\Data).
- Call Product Support for a zip file that will reattach this file.
- Go into DbCreate and select the “Upgrade” option. Then force an upgrade to resynch the SQL database.