Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84643members
353975posts

Schneider_ATV_320 not ready problem

Industry Automation and Control Forum

This forum is addressing industrial automation design & engineering, operations, asset performance, cyber security and digital transformation for Plants & Machines.

veki1992
Cadet
0 Likes
7
3470

Schneider_ATV_320 not ready problem

Hello, 

I setup an ATV 320 V.F.D. in IO profile mode,
as I started the motor I receive status word from V.F.D. : 

Ready to switch, Ready to operate and error.

While the motor is running we get Boolean state "FALSE" on signals as if V.F.D. is not ready to switch and it is not ready to operate.
We don't get error information, V.F.D. just stops the motor and waits for the next command.Ready to switch and ready to operate signals stay FALSE until i reset "RUN" bit in command word. After that they go back to state "TRUE".

 

This all happens in process where we simply want to run our motor constantly without turning off, and we don't have any idea why would it suddenly in the running state stop being ready and waiting for next command as if his command is always be running.. 

Could anyone help me with this one? 

Thank You

7 Replies 7
Oncom
Commander
Commander
0 Likes
4
3450

Re: Schneider_ATV_320 not ready problem

Are you sending command through modbus from PLC? 

if yes, make sure this command always send periodically. if it doesn't, VSD will back to ready state for safety reason.

Eric_Coudurier
Lt. Commander Lt. Commander
Lt. Commander

Re: Schneider_ATV_320 not ready problem

Hello,

There is a communication control on Modbus, the ATV controls that there are requests sent periodically. Normally if you read the status of the ATV periodically, it is enough to maintain the control of the communication.

Here after an extract from the documentation:

2020-02-10_09-51-54.png

 

veki1992
Cadet
0 Likes
2
3415

Re: Schneider_ATV_320 not ready problem

Hello, thank You for your reply,

 

I am sending the command word via Profinet every communication cycle. The drive is fitted with VW3A3627 module. 2 out of 14 drives are the only ones to have this problem. 

Oncom
Commander
Commander
0 Likes
0
3397

Re: Schneider_ATV_320 not ready problem

@veki1992 

you can try to switch over the 2 VSD IP address with a good one.

if the problem appear on new IP (old VSD) the source of problem could be on VSD configuration. 

if the problem appear on old IP, then your problem could be on your PLC setting/program.

 

BevanWeiss
Spock
Spock
0 Likes
0
3392

Re: Schneider_ATV_320 not ready problem

Do all of the drives have identical configurations? (the answer to this should of course be 'no', since they likely have different motors / different node addresses)

But importantly, is the SLL [Modus fault Mgt] field set to 'no' on ALL of the drives?

 

Make sure that safety is afforded in a more robust manner than just using this setting of course.. otherwise death may occur.


Lead Control Systems Engineer for Alliance Automation (VIC).
All opinions are my own and do not represent the opinions or policies of my employer, or of my cat..
Folkan101
Crewman
Crewman
0 Likes
1
2819

Re: Schneider_ATV_320 not ready problem

@veki1992 

 

Hii veki, i just done my proheject controling atv12 via modbus using hmi gxu3511, if you communicate direct without PLC, make sure the reference channal and command channel in right configuration example 'reference channel  is set to modbus (ndb)'  and command channel (cd1) is set to ndb, you must set the value is in special addres in my case is 8502(reference freq) and 8501(command channel) set 6, 7, 15( to run the drive ) refers to modbus communication manuals, atv320  communication parameter

(excel file ) 

Tags (1)
Folkan101
Crewman
Crewman
0 Likes
0
2817

Re: Schneider_ATV_320 not ready problem

And if using plc make sure that plc have special flag clock

Tags (1)