Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84690members
354060posts

Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

EcoStruxure IT forum

A support forum for Data Center Operation, Data Center Expert, and EcoStruxure IT product users to share knowledge on installation, configuration, and general product use.

DCIM_Support
Picard
Picard
0 Likes
8
521

Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This question was originally posted on DCIM Support by Danny Guerrero on 2018-10-01


Hello,

 

Unable to even start DCE after updating it to its newer FW 7.5.0

My colleague updated it over the weekend and its working fine for him however, when I download the client via webGUI, and finish installing the client, when I try to open the client, I get "An error has occurred. See the log file"

Here is the log file it points to :

!SESSION 2018-10-01 10:55:00.358 -----------------------------------------------

eclipse.buildId=unknown

java.version=1.8.0_151

java.vendor=Oracle Corporation

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

Command-line arguments:  -os win32 -ws win32 -arch x86

 

!ENTRY org.eclipse.equinox.common 4 0 2018-10-01 10:55:01.586

!MESSAGE

!STACK 0

org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.common_3.6.0.v20100503 [1]" could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.osgi.framework.log; version="0.0.0"

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)

    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)

    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)

    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)

    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

 

!ENTRY org.eclipse.update.configurator 4 0 2018-10-01 10:55:01.602

!MESSAGE

!STACK 0

org.osgi.framework.BundleException: The bundle "org.eclipse.update.configurator_3.3.100.v20100512 [2]" could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)

    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)

    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)

    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)

    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

 

!ENTRY org.eclipse.core.runtime 4 0 2018-10-01 10:55:01.602

!MESSAGE

!STACK 0

org.osgi.framework.BundleException: The bundle "org.eclipse.core.runtime_3.6.0.v20100505 [3]" could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.5.0,4.0.0)"

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)

    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)

    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)

    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)

    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)

    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)

    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)

 

!ENTRY org.eclipse.osgi 4 0 2018-10-01 10:55:01.617

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.common_3.6.0.v20100503.jar/ was not resolved.

 

!ENTRY org.eclipse.osgi 4 0 2018-10-01 10:55:01.617

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.3.100.v20100512.jar/ was not resolved.

 

!ENTRY org.eclipse.osgi 4 0 2018-10-01 10:55:01.617

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.6.0.v20100505.jar/ was not resolved.

 

!ENTRY org.eclipse.osgi 2 0 2018-10-01 10:55:01.649

!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-10-01 10:55:01.649

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.6.0.v20100505.jar/ was not resolved.

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.649

!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.649

!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.649

!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.649

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.664

!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

 

!ENTRY org.eclipse.osgi 2 0 2018-10-01 10:55:01.664

!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-10-01 10:55:01.664

!MESSAGE Bundle org.eclipse.equinox.common_3.6.0.v20100503 [1] was not resolved.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.664

!MESSAGE Missing imported package org.eclipse.osgi.framework.log_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.eclipse.osgi.service.datalocation_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.eclipse.osgi.service.debug_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.eclipse.osgi.service.localization_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.eclipse.osgi.service.urlconversion_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.osgi.service.url_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.eclipse.osgi.util_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.osgi.framework_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.osgi.service.packageadmin_0.0.0.

!SUBENTRY 2 org.eclipse.equinox.common 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.osgi.util.tracker_0.0.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-10-01 10:55:01.680

!MESSAGE Bundle org.eclipse.update.configurator_3.3.100.v20100512 [2] was not resolved.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package javax.xml.parsers_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.w3c.dom_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.xml.sax_0.0.0.

!SUBENTRY 2 org.eclipse.update.configurator 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.

!SUBENTRY 1 org.eclipse.osgi 2 0 2018-10-01 10:55:01.680

!MESSAGE Bundle org.eclipse.core.runtime_3.6.0.v20100505 [3] was not resolved.

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.5.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.4.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.3.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing required bundle org.eclipse.equinox.app_[1.0.0,2.0.0).

!SUBENTRY 2 org.eclipse.core.runtime 2 0 2018-10-01 10:55:01.680

!MESSAGE Missing dynamically imported package org.eclipse.core.internal.runtime.auth_0.0.0.

 

!ENTRY org.eclipse.osgi 4 0 2018-10-01 10:55:01.680

!MESSAGE Application error

!STACK 1

java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)

    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)

    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)

    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)

 

 

 

 

 

Sorry for the mess. Is there anything anyone can suggest I try? I have already uninstalled and reinstall many times over and have deleted anything from the previous DCE build, restarted my computer many times as well. Any suggestions would be greatly appreciated.

 

 

Danny

 

(CID:134037859)

Tags (1)
8 Replies 8
DCIM_Support
Picard
Picard
0 Likes
6
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This answer was originally posted on DCIM Support by Jef Faridi on 2018-10-02


Hi Danny,

Is it correctly understood that you have tried to upgrade your DCE directly from 7.2 to 7.5 ?

If yes, then that is not supported! That should be a sequential upgrade so you will need to apply the upgrades in the following order:

7.2.0->7.2.1->7.2.2->7.2.4->7.2.5->7.2.6->7.2.7->7.3.1->7.4.0->7.4.1->7.5

You can watch the upgrade progress from the server web page. Once the upgrade completes, download & install the updated client, login, make a backup, and start the next upgrade.

 

Assuming your upgrade was successful (and had already followed the supported path), then try to uninstall the software (from your workstation), remove the client temp files (usually located in C:\Users\<user name>\.isxc\"dce version(s)"), and then "Download Client" installer (from server https://<server ip>) and install it.

Kind regards

(CID:134680274)

DCIM_Support
Picard
Picard
0 Likes
0
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This comment was originally posted on DCIM Support by Danny Guerrero on 2018-10-02


This would make sense, however, my colleague has a working 7.5.0 client. And as I mentioned, the webGUI is working fine. So it seems like everything is working but the client.

(CID:134680279)

DCIM_Support
Picard
Picard
0 Likes
0
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This comment was originally posted on DCIM Support by Jef Faridi on 2018-10-03


Hi Danny,

Your client logs complaining about "java.lang.IllegalStateException: Unable to acquire application service." So, if everything is okay on server side, then it might make sense to compare the two clients (working client vs. your machine) that might help you to narrow down the issue. (I would check/compare OS, Java, possible scanning/antivirus programs, etc.).

Have you tried to test/install the client on another workstation and see if it works?

Kind regards

(CID:134680283)

DCIM_Support
Picard
Picard
0 Likes
0
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This comment was originally posted on DCIM Support by Danny Guerrero on 2018-10-03


Looks like we are both on Windows 10 and on the latest version of Java (jre1.8.0_181).

I went ahead and deleted C:\Users\<user name>\.isxc\7.2.7 and allowed access to the app through firewall. Still no dice.

Any other suggestions? This is killing me. Thanks for your help so far.

(CID:134680287)

DCIM_Support
Picard
Picard
0 Likes
0
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This comment was originally posted on DCIM Support by Jef Faridi on 2018-10-04


Hi Danny,

If your DCE server version is 7.5, then you might want to clear the C:\Users\<user name>\.isxc\7.5.0 folder. (you can actually remove all 7.* folders).

And make sure that client software (installer) have been downloaded from the server itself (log in to https://<DCE server IP>, and then go to "Download Client").

If that doesn't help, I'm not sure what might be the issue with your workstation.

Wondering if you have tested the client on another work station (in your network)?

Kind regards

(CID:134680291)

DCIM_Support
Picard
Picard
0 Likes
0
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This comment was originally posted on DCIM Support by Danny Guerrero on 2018-10-05


So I got it working... Very silly but I had to open the installer under "Run as Administrator".

 

I had tried this but opening the client as Administrator but I never tried opening the installer that way until now.

 

Thanks for your help through this Jef!

 

Danny

(CID:134680295)

DCIM_Support
Picard
Picard
0 Likes
0
521

Re: Upgraded DCE from 7.2.0 to 7.5.0 and having issues with Java/Eclipse

This comment was originally posted on DCIM Support by Jef Faridi on 2018-10-08


Hi Danny,

You are most welcome, I'm really happy to hear the good news & many thanks for the update!

Kind regards

(CID:134680299)

DCIM_Support
Picard
Picard
0 Likes
0
521

🔒 Closed

This question is closed for comments. You're welcome to start a new topic if you have further comments on this issue.