Issue
When starting the Vista Server, the splash screen displays the current state of the startup. It gets to the "Trend Log Initialization" screen and then hangs.
Product Line
TAC Vista
Environment
Vista Server
Cause
Queued files in the $queues folder in the Vista database are being written to the SQL database. If the queued files folder has grown very large, it can take a very long time (hours) to write this data to SQL. If the connection to the SQL database has been broken, then it will take an infinite amount of time.
Resolution
Check for queued files in the $queues folder
- Navigate in a Windows Explorer window to the Vista Database. (If you are unsure of the location, you can verify it in the TAC Vista Server Setup Vista Database tab).
- Go to the $queues folder
- Look inside the insertevents and insertlogvalues folders. This is where data is stored temporarily before it is written to the SQL database. Having queued files is not necessarily a sign of a problem. However, if there is a connection problem, these folders will continually grow in size without older queued files being written from the folder.
Allow time for the files to write the SQL
- Start Vista Server.
- Insure that TAC DSS Writer Service is running.
- When it gets to trend log initialization, leave the PC alone and allow time for the files to write to the SQL server. If the size of the $queues folders are shrinking, then the process is working and after enough time, the server will start.
Note: If you have cleared the $queues folder but it still hangs on trend log initialization, still allow plenty of time for the server to come up. There is a good chance that the Xenta controllers are passing all of their trend logs over to the SQL server. This could take hours or even overnight to complete.
Delete the queued files
- If the data is not of dire importance, delete all the files inside both of the $queues folder. For an efficient method for deleting many queued files, see An efficient method for deleting all queued files in the $queues folder.
Check the SQL connection
- Open the TAC Vista Server Setup
- In version 5.1.3 and prior: Start > Programs > TAC > TAC Vista Server X.X.X > Server Setup
- In version 5.1.4 and later: Start > Programs > Schneider Electric > TAC Vista Server X.X.X > Server Setup
- Go to the SQL Server tab
- In the lower right-hand corner of the tab, press the Test Connection button.
- If it pops up a window that says "Connection test succeeded!" then your SQL connection is okay.
- If it fails the connection test, check the instance name. If you are using default settings it should be:
SQL Server name: PCname\TACVISTA or (local)\TACVISTA
Log database name: taclogdata - If these are set correctly and the connection still fails, one method for reestablishing the connection is to uninstall/reinstall the Vista software.
Remove TRL files
This can also occur if the database has been upgraded from a lower versions, and still has information in the TRL files in the database.
- Stop the server
- Locate all TRL files in the $thisfil folder
- Delete any TRL file over 32Kb.
- Start the server again.